Asterisk 15.x < 15.2.2 Denial of Service Vulnerability (AST-2018-006)

medium Nessus Plugin ID 110568
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A telephony application running on the remote host is affected by a denial of service vulnerability.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 15.x prior to 15.2.2. It is therefore, affected by a denial of service vulnerability as described in AST-2018-006 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 15.2.2 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2018-006.html

Plugin Details

Severity: Medium

ID: 110568

File Name: asterisk_ast_2018_006.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 6/15/2018

Updated: 11/4/2019

Dependencies: asterisk_detection.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2018-7287

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, asterisk/sip_detected

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2018

Vulnerability Publication Date: 2/5/2018

Reference Information

CVE: CVE-2018-7287