Asterisk 13.x < 13.21.1 / 14.x < 14.7.7 / 13.13 < 13.18-cert4 / 13.21 < 13.21-cert2 Information Disclosure Vulnerability (AST-2018-008)

Medium Nessus Plugin ID 110562

Synopsis

A telephony application running on the remote host is affected by a remote denial of service vulnerability.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.21.1, 14.x prior to 14.7.7, or 13.18 prior to 13.18-cert4. It is therefore, affected by a remote denial of service attack as described in AST-2018-008.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 13.21.1 / 14.7.7 / 13.18-cert4 / 13.21-cert2 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2018-008.html

Plugin Details

Severity: Medium

ID: 110562

File Name: asterisk_ast_2018_008.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 2018/06/15

Updated: 2018/12/07

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12227

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Patch Publication Date: 2018/06/11

Vulnerability Publication Date: 2018/04/19

Reference Information

CVE: CVE-2018-12227