Asterisk 13.x < 13.21.1 / 14.x < 14.7.7 / 13.13 < 13.18-cert4 / 13.21 < 13.21-cert2 Information Disclosure Vulnerability (AST-2018-008)

Medium Nessus Plugin ID 110562


A telephony application running on the remote host is affected by a remote denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 13.x prior to 13.21.1, 14.x prior to 14.7.7, or 13.18 prior to 13.18-cert4. It is therefore, affected by a remote denial of service attack as described in AST-2018-008.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 13.21.1 / 14.7.7 / 13.18-cert4 / 13.21-cert2 or later.

See Also

Plugin Details

Severity: Medium

ID: 110562

File Name: asterisk_ast_2018_008.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 2018/06/15

Updated: 2019/11/04

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12227

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/06/11

Vulnerability Publication Date: 2018/04/19

Reference Information

CVE: CVE-2018-12227