Asterisk 15.x < 15.4.1 Multiple Vulnerabilities (AST-2018-007 - AST-2018-008)

Medium Nessus Plugin ID 110561

Synopsis

A telephony application running on the remote host is affected by multiple vulnerabilities.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 15.x prior to 15.4.1. It is therefore, affected by multiple vulnerabilities as described in AST-2018-007 & AST-2018-008 advisories.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 15.4.1 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2018-007.html

http://downloads.asterisk.org/pub/security/AST-2018-008.html

Plugin Details

Severity: Medium

ID: 110561

File Name: asterisk_ast_15_x_2018_007-008.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2018/06/15

Updated: 2018/12/07

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12228

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Patch Publication Date: 2018/06/11

Vulnerability Publication Date: 2018/06/11

Reference Information

CVE: CVE-2018-12227, CVE-2018-12228