GLSA-201806-03 : BURP: Multiple vulnerabilities

Low Nessus Plugin ID 110524

Synopsis

The remote Gentoo host is missing one or more security-related
patches.

Description

The remote host is affected by the vulnerability described in GLSA-201806-03
(BURP: Multiple vulnerabilities)

It was discovered that Gentoo’s BURP ebuild does not properly set
permissions or place the pid file in a safe directory.
Impact :

A local attacker could escalate privileges.
Workaround :

Users should ensure the proper permissions are set as discussed in the
referenced bugs.

Solution

All BURP users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-backup/burp-2.1.32'

See Also

https://security.gentoo.org/glsa/201806-03

Plugin Details

Severity: Low

ID: 110524

File Name: gentoo_GLSA-201806-03.nasl

Version: 1.4

Type: local

Published: 2018/06/14

Modified: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

CVSS v3.0

Base Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:burp, cpe:/o:gentoo:linux

Patch Publication Date: 2018/06/13

Reference Information

CVE: CVE-2017-18284, CVE-2017-18285

GLSA: 201806-03