Security Updates for Microsoft Sharepoint Server (June 2018)

Medium Nessus Plugin ID 110497

Synopsis

The Microsoft Sharepoint Server installation on the remote host is affected by multiple vulnerabilities.

Description

The Microsoft Sharepoint Server installation on the remote host is missing security updates. It is, therefore, affected by multiple vulnerabilities :

- An elevation of privilege vulnerability exists when Microsoft SharePoint Server does not properly sanitize a specially crafted web request to an affected SharePoint server. An authenticated attacker could exploit the vulnerability by sending a specially crafted request to an affected SharePoint server. The attacker who successfully exploited the vulnerability could then perform cross-site scripting attacks on affected systems and run script in the security context of the current user. These attacks could allow the attacker to read content that the attacker is not authorized to read, use the victim's identity to take actions on the SharePoint site on behalf of the user, such as change permissions and delete content, and inject malicious content in the browser of the user. The security update addresses the vulnerability by helping to ensure that SharePoint Server properly sanitizes web requests. (CVE-2018-8252, CVE-2018-8254)

Solution

Microsoft has released the following security updates to address this issue:
-KB4022179
-KB4022173
-KB4022210
-KB4018391
-KB4022190
-KB4022197

See Also

http://www.nessus.org/u?d55fcf27

http://www.nessus.org/u?dbe95a40

http://www.nessus.org/u?f7ab8557

http://www.nessus.org/u?a24384e1

http://www.nessus.org/u?4a73b0a8

http://www.nessus.org/u?1d0d1103

Plugin Details

Severity: Medium

ID: 110497

File Name: smb_nt_ms18_jun_office_sharepoint.nasl

Version: 1.3

Type: local

Agent: windows

Published: 2018/06/12

Modified: 2018/07/13

Dependencies: 13855, 74250, 57033

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:microsoft:sharepoint, cpe:/a:microsoft:project_server, cpe:/a:microsoft:office

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Patch Publication Date: 2018/06/12

Vulnerability Publication Date: 2018/06/12

Reference Information

CVE: CVE-2018-8252, CVE-2018-8254

MSKB: 4022179, 4022173, 4022210, 4018391, 4022190, 4022197

MSFT: MS18-4022179, MS18-4022173, MS18-4022210, MS18-4018391, MS18-4022190, MS18-4022197

IAVA: 2018-A-0192