Debian DSA-4218-1 : memcached - security update

Medium Nessus Plugin ID 110386

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in memcached, a high-performance memory object caching system. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2017-9951 Daniel Shapira reported a heap-based buffer over-read in memcached (resulting from an incomplete fix for CVE-2016-8705 ) triggered by specially crafted requests to add/set a key and allowing a remote attacker to cause a denial of service.

- CVE-2018-1000115 It was reported that memcached listens to UDP by default. A remote attacker can take advantage of it to use the memcached service as a DDoS amplifier.

Default installations of memcached in Debian are not affected by this issue as the installation defaults to listen only on localhost.
This update disables the UDP port by default. Listening on the UDP can be re-enabled in the /etc/memcached.conf (cf.
/usr/share/doc/memcached/NEWS.Debian.gz).

- CVE-2018-1000127 An integer overflow was reported in memcached, resulting in resource leaks, data corruption, deadlocks or crashes.

Solution

Upgrade the memcached packages.

For the oldstable distribution (jessie), these problems have been fixed in version 1.4.21-1.1+deb8u2.

For the stable distribution (stretch), these problems have been fixed in version 1.4.33-1+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=868701

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=894404

https://security-tracker.debian.org/tracker/CVE-2017-9951

https://security-tracker.debian.org/tracker/CVE-2016-8705

https://security-tracker.debian.org/tracker/CVE-2018-1000115

https://security-tracker.debian.org/tracker/CVE-2018-1000127

https://security-tracker.debian.org/tracker/source-package/memcached

https://packages.debian.org/source/jessie/memcached

https://packages.debian.org/source/stretch/memcached

https://www.debian.org/security/2018/dsa-4218

Plugin Details

Severity: Medium

ID: 110386

File Name: debian_DSA-4218.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/06/07

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:memcached, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Patch Publication Date: 2018/06/06

Reference Information

CVE: CVE-2017-9951, CVE-2018-1000115, CVE-2018-1000127

DSA: 4218