CentOS 7 : corosync (CESA-2018:1169)

critical Nessus Plugin ID 110239

Synopsis

The remote CentOS host is missing one or more security updates.

Description

An update for corosync is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The corosync packages provide the Corosync Cluster Engine and C APIs for Red Hat Enterprise Linux cluster software.

Security Fix(es) :

* corosync: Integer overflow in exec/totemcrypto.c:authenticate_nss_2_3() function (CVE-2018-1084)

For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.

Red Hat would like to thank Citrix Security Response Team for reporting this issue.

Solution

Update the affected corosync packages.

See Also

http://www.nessus.org/u?348bc1f7

Plugin Details

Severity: Critical

ID: 110239

File Name: centos_RHSA-2018-1169.nasl

Version: 1.6

Type: local

Agent: unix

Published: 5/31/2018

Updated: 12/31/2019

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2018-1084

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:centos:centos:corosync, p-cpe:/a:centos:centos:corosync-qdevice, p-cpe:/a:centos:centos:corosync-qnetd, p-cpe:/a:centos:centos:corosynclib, p-cpe:/a:centos:centos:corosynclib-devel, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Patch Publication Date: 5/30/2018

Vulnerability Publication Date: 4/12/2018

Reference Information

CVE: CVE-2018-1084

RHSA: 2018:1169

IAVA: 2018-A-0127