Debian DSA-4212-1 : git - security update

Medium Nessus Plugin ID 110207

Synopsis

The remote Debian host is missing a security-related update.

Description

Etienne Stalmans discovered that git, a fast, scalable, distributed revision control system, is prone to an arbitrary code execution vulnerability exploitable via specially crafted submodule names in a .gitmodules file.

Solution

Upgrade the git packages.

For the oldstable distribution (jessie), this problem has been fixed in version 1:2.1.4-2.1+deb8u6.

For the stable distribution (stretch), this problem has been fixed in version 1:2.11.0-3+deb9u3.

See Also

https://security-tracker.debian.org/tracker/source-package/git

https://packages.debian.org/source/jessie/git

https://packages.debian.org/source/stretch/git

https://www.debian.org/security/2018/dsa-4212

Plugin Details

Severity: Medium

ID: 110207

File Name: debian_DSA-4212.nasl

Version: 1.6

Type: local

Agent: unix

Published: 2018/05/30

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:git, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/05/29

Reference Information

CVE: CVE-2018-11235

DSA: 4212