Amazon Linux 2 : nghttp2 (ALAS-2018-1020)

high Nessus Plugin ID 110193
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
(CVE-2018-1000168)

Solution

Run 'yum update nghttp2' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2018-1020.html

Plugin Details

Severity: High

ID: 110193

File Name: al2_ALAS-2018-1020.nasl

Version: 1.3

Type: local

Agent: unix

Published: 5/30/2018

Updated: 8/31/2018

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:o:amazon:linux:2:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:libnghttp2:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:libnghttp2-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:nghttp2:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:nghttp2-debuginfo:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 5/24/2018

Reference Information

CVE: CVE-2018-1000168

ALAS: 2018-1020