GLSA-201805-12 : NTP: Multiple vulnerabilities

High Nessus Plugin ID 110176

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201805-12 (NTP: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in NTP. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could possibly execute arbitrary code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All NTP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/ntp-4.2.8_p11'

See Also

https://security.gentoo.org/glsa/201805-12

Plugin Details

Severity: High

ID: 110176

File Name: gentoo_GLSA-201805-12.nasl

Version: 1.4

Type: local

Published: 2018/05/29

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ntp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/05/26

Reference Information

CVE: CVE-2018-7170, CVE-2018-7182, CVE-2018-7183, CVE-2018-7184, CVE-2018-7185

GLSA: 201805-12