Adobe Photoshop CC 18.x < 18.1.4 / 19.x < 19.1.4 Remote Code Execution Vulnerability (APSB18-17) (macOS)

High Nessus Plugin ID 109865

Synopsis

The remote host has an application installed that is affected by a remote code execution vulnerability.

Description

The version of Adobe Photoshop CC installed on the remote macOS or Mac OS X host is 18.x prior to 18.1.4 (2017.1.4) or 19.x prior to 19.1.4 (2018.1.4). It is, therefore, affected by an unspecified remote code execution vulnerability.

Solution

Upgrade to Adobe Photoshop CC 18.1.4 (2017.1.4), 19.1.4 (2018.1.4), or later.

See Also

https://helpx.adobe.com/security/products/photoshop/apsb18-17.html

Plugin Details

Severity: High

ID: 109865

File Name: macos_adobe_photoshop_apsb18-17.nasl

Version: 1.2

Type: local

Agent: macosx

Published: 2018/05/17

Modified: 2018/05/17

Dependencies: 62220

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:adobe:photoshop_cc

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Photoshop

Patch Publication Date: 2018/05/14

Vulnerability Publication Date: 2018/05/14

Reference Information

CVE: CVE-2018-4946

BID: 104171

IAVA: 2018-A-0158