Debian DLA-1378-1 : tiff3 security update

Medium Nessus Plugin ID 109738

Synopsis

The remote Debian host is missing a security update.

Description

A heap-based buffer overflow was discovered in the LZWDecodeCompat function in tif_lzw.c (LibTIFF 4.0.9 and earlier). This vulnerability might be leveraged by remote attackers to crash the client via a crafted TIFF LZW file.

For Debian 7 'Wheezy', these problems have been fixed in version 3.9.6-11+deb7u11.

We recommend that you upgrade your tiff3 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/05/msg00009.html

https://packages.debian.org/source/wheezy/tiff3

Plugin Details

Severity: Medium

ID: 109738

File Name: debian_DLA-1378.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/05/14

Updated: 2018/08/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libtiff4, p-cpe:/a:debian:debian_linux:libtiff4-dev, p-cpe:/a:debian:debian_linux:libtiffxx0c2, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/05/13

Reference Information

CVE: CVE-2018-8905