Scientific Linux Security Update : libvncserver on SL7.x x86_64 (20180410)

High Nessus Plugin ID 109451

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- libvncserver: Improper input sanitization in rfbProcessClientNormalMessage in rfbserver.c (CVE-2018-7225)

Solution

Update the affected libvncserver, libvncserver-debuginfo and / or libvncserver-devel packages.

See Also

http://www.nessus.org/u?813a61d9

Plugin Details

Severity: High

ID: 109451

File Name: sl_20180410_libvncserver_on_SL7_x.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/05/01

Updated: 2020/02/24

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:fermilab:scientific_linux:libvncserver, p-cpe:/a:fermilab:scientific_linux:libvncserver-debuginfo, p-cpe:/a:fermilab:scientific_linux:libvncserver-devel, x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2018/04/10

Vulnerability Publication Date: 2018/02/19

Reference Information

CVE: CVE-2018-7225