Debian DLA-1367-1 : slurm-llnl security update

High Nessus Plugin ID 109408

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2018-7033 An issue that could be used for SQL Injection attacks against SlurmDBD has been fixed.

For Debian 7 'Wheezy', these problems have been fixed in version 2.3.4-2+deb7u2.

We recommend that you upgrade your slurm-llnl packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/04/msg00032.html

https://packages.debian.org/source/wheezy/slurm-llnl

Plugin Details

Severity: High

ID: 109408

File Name: debian_DLA-1367.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/04/30

Updated: 2018/08/31

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libpam-slurm, p-cpe:/a:debian:debian_linux:libpmi0, p-cpe:/a:debian:debian_linux:libpmi0-dev, p-cpe:/a:debian:debian_linux:libslurm-dev, p-cpe:/a:debian:debian_linux:libslurm-perl, p-cpe:/a:debian:debian_linux:libslurm23, p-cpe:/a:debian:debian_linux:libslurmdb-dev, p-cpe:/a:debian:debian_linux:libslurmdb-perl, p-cpe:/a:debian:debian_linux:libslurmdb23, p-cpe:/a:debian:debian_linux:slurm-llnl, p-cpe:/a:debian:debian_linux:slurm-llnl-basic-plugins, p-cpe:/a:debian:debian_linux:slurm-llnl-basic-plugins-dev, p-cpe:/a:debian:debian_linux:slurm-llnl-doc, p-cpe:/a:debian:debian_linux:slurm-llnl-slurmdbd, p-cpe:/a:debian:debian_linux:slurm-llnl-sview, p-cpe:/a:debian:debian_linux:slurm-llnl-torque, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/04/28

Reference Information

CVE: CVE-2018-7033