Debian DLA-1362-1 : gcc-4.9-backport new package

High Nessus Plugin ID 109346

Synopsis

The remote Debian host is missing a security update.

Description

GCC 4.9 has been packaged as gcc-4.9-backport for Debian 7. This package will be needed by future updates to linux, and possibly other packages, to implement the 'retpoline' mitigation for CVE-2017-5715 (Spectre variant 2).

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected gcc-4.9-backport package.

See Also

https://lists.debian.org/debian-lts-announce/2018/04/msg00027.html

https://packages.debian.org/source/wheezy/gcc-4.9-backport

Plugin Details

Severity: High

ID: 109346

File Name: debian_DLA-1362.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/04/26

Updated: 2018/04/26

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gcc-4.9-backport, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/04/25