Drupal 7.x < 7.59 / 8.4.x < 8.4.8 / 8.5.x < 8.5.3 Remote Code Execution Vulnerability (SA-CORE-2018-004)

Critical Nessus Plugin ID 109344

Synopsis

A PHP application running on the remote web server is affected by a remote code execution vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.59, 8.4.x prior to 8.4.8, or 8.5.x prior to 8.5.3. It is, therefore, affected by a remote code execution vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 7.59 / 8.4.8 / 8.5.3 or later.

See Also

https://www.drupal.org/SA-CORE-2018-004

https://www.drupal.org/project/drupal/releases/7.59

https://www.drupal.org/project/drupal/releases/8.4.8

https://www.drupal.org/project/drupal/releases/8.5.3

Plugin Details

Severity: Critical

ID: 109344

File Name: drupal_8_5_3.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2018/04/25

Updated: 2019/04/30

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/04/25

Vulnerability Publication Date: 2018/04/25

Exploitable With

Elliot (Drupal 7 SA-CORE-2018-004 RCE)

Reference Information

CVE: CVE-2018-7602