Debian DSA-4179-1 : linux-tools - security update

High Nessus Plugin ID 109329

Synopsis

The remote Debian host is missing a security-related update.

Description

This update doesn't fix a vulnerability in linux-tools, but provides support for building Linux kernel modules with the 'retpoline'mitigation for CVE-2017-5715 (Spectre variant 2).

This update also includes bug fixes from the upstream Linux 3.16 stable branch up to and including 3.16.56.

Solution

Upgrade the linux-tools packages.

For the oldstable distribution (jessie), this problem has been fixed in version 3.16.56-1.

See Also

https://security-tracker.debian.org/tracker/CVE-2017-5715

https://security-tracker.debian.org/tracker/source-package/linux-tools

https://packages.debian.org/source/jessie/linux-tools

https://www.debian.org/security/2018/dsa-4179

Plugin Details

Severity: High

ID: 109329

File Name: debian_DSA-4179.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/04/25

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:linux-tools, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/04/24

Reference Information

DSA: 4179