Debian DLA-1349-1 : linux-tools security update

High Nessus Plugin ID 109064

Synopsis

The remote Debian host is missing a security update.

Description

This update doesn't fix a vulnerability in linux-tools, but provides support for building Linux kernel modules with the 'retpoline' mitigation for CVE-2017-5715 (Spectre variant 2).

This update also includes bug fixes from the upstream Linux 3.2 stable branch up to and including 3.2.101.

For Debian 7 'Wheezy', these problems have been fixed in version 3.2.101-1.

We recommend that you upgrade your linux-tools packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/04/msg00014.html

https://packages.debian.org/source/wheezy/linux-tools

Plugin Details

Severity: High

ID: 109064

File Name: debian_DLA-1349.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/04/17

Updated: 2018/04/17

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libusbip-dev, p-cpe:/a:debian:debian_linux:linux-kbuild-3.2, p-cpe:/a:debian:debian_linux:linux-tools-3.2, p-cpe:/a:debian:debian_linux:usbip, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/04/16