Debian DLA-1341-1 : sdl-image1.2 security update

high Nessus Plugin ID 108902

Synopsis

The remote Debian host is missing a security update.

Description

Lilith of Cisco Talos discovered several buffer overflow vulnerabilities in the SDL Image library which can be leveraged by attackers to execute arbitrary code via specially crafted image files.

For Debian 7 'Wheezy', these problems have been fixed in version 1.2.12-2+deb7u2.

We recommend that you upgrade your sdl-image1.2 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/04/msg00005.html

https://packages.debian.org/source/wheezy/sdl-image1.2

Plugin Details

Severity: High

ID: 108902

File Name: debian_DLA-1341.nasl

Version: 1.5

Type: local

Agent: unix

Published: 4/10/2018

Updated: 1/11/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libsdl-image1.2, p-cpe:/a:debian:debian_linux:libsdl-image1.2-dev, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 4/6/2018

Reference Information

CVE: CVE-2017-12122, CVE-2017-14440, CVE-2017-14441, CVE-2017-14442, CVE-2017-14448, CVE-2017-14450