GLSA-201804-02 : glibc: Multiple vulnerabilities

High Nessus Plugin ID 108822

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201804-02 (glibc: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in glibc. Please review the CVE identifiers referenced below for details.
Impact :

An attacker could possibly execute arbitrary code, escalate privileges, cause a Denial of Service condition, or have other unspecified impacts.
Workaround :

There is no known workaround at this time.

Solution

All glibc users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/glibc-2.25-r11'

See Also

https://security.gentoo.org/glsa/201804-02

Plugin Details

Severity: High

ID: 108822

File Name: gentoo_GLSA-201804-02.nasl

Version: 1.4

Type: local

Published: 2018/04/04

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:glibc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/04/04

Exploitable With

Metasploit (glibc "realpath()" Privilege Escalation)

Reference Information

CVE: CVE-2017-14062, CVE-2017-15670, CVE-2017-15671, CVE-2017-15804, CVE-2017-16997, CVE-2018-1000001, CVE-2018-6485, CVE-2018-6551

GLSA: 201804-02