Mozilla Firefox < 59.0.2 Denial of Service Vulnerability (macOS)

High Nessus Plugin ID 108754

Synopsis

A web browser installed on the remote macOS or Mac OS X host is affected by a Denial of Service vulnerability.

Description

The version of Mozilla Firefox installed on the remote macOS or Mac OS X host is prior to 59.0.2. It is, therefore, affected by a use-after-free error that causes a denial of service vulnerability.

Solution

Upgrade to Mozilla Firefox version 59.0.2 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2018-10/

Plugin Details

Severity: High

ID: 108754

File Name: macos_firefox_59_0_2.nasl

Version: 1.4

Type: local

Agent: macosx

Published: 2018/03/30

Updated: 2018/08/10

Dependencies: 55417

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Patch Publication Date: 2018/03/26

Vulnerability Publication Date: 2018/03/26

Reference Information

CVE: CVE-2018-5148

BID: 103506

MFSA: 2018-10