Drupal 7.x < 7.58 / 8.3.x < 8.3.9 / 8.4.x < 8.4.6 / 8.5.x < 8.5.1 Remote Code Execution Vulnerability (SA-CORE-2018-002)

High Nessus Plugin ID 108688

Synopsis

A PHP application running on the remote web server is affected by a remote code execution vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.58, 8.3.x prior to 8.3.9, 8.4.x prior to 8.4.6, or 8.5.x prior to 8.5.1. It is, therefore, affected by a remote code execution vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 7.58 / 8.3.9 / 8.4.6 / 8.5.1 or later.

See Also

https://www.drupal.org/SA-CORE-2018-002

https://www.drupal.org/project/drupal/releases/7.58

https://www.drupal.org/project/drupal/releases/8.3.9

https://www.drupal.org/project/drupal/releases/8.4.6

https://www.drupal.org/project/drupal/releases/8.5.1

Plugin Details

Severity: High

ID: 108688

File Name: drupal_8_5_1.nasl

Version: 1.16

Type: remote

Family: CGI abuses

Published: 2018/03/28

Updated: 2019/06/04

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-7600

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/28

Exploitable With

Core Impact

Metasploit (Drupal Drupalgeddon 2 Forms API Property Injection)

Elliot (Drupal 8 SA-CORE-2018-002 RCE)

Reference Information

CVE: CVE-2018-7600