Samba 4.5.x < 4.5.16 / 4.6.x < 4.6.14 / 4.7.x < 4.7.6 Multiple Vulnerabilities

Medium Nessus Plugin ID 108378

Synopsis

The remote Samba server is affected by multiple vulnerabilities.

Description

The version of Samba running on the remote host is 4.5.x prior to 4.5.16, or 4.6.x prior to 4.6.14, or 4.7.x prior to 4.7.6. It is, therefore, affected by a remote DoS and a remote password manipulation vulnerability.

Note: Refer to the advisories for possible workarounds.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 4.5.16 / 4.6.14 / 4.7.6 or later.

See Also

https://www.samba.org/samba/security/CVE-2018-1050.html

https://www.samba.org/samba/security/CVE-2018-1057.html

https://www.samba.org/samba/history/samba-4.5.16.html

https://www.samba.org/samba/history/samba-4.6.14.html

https://www.samba.org/samba/history/samba-4.7.6.html

Plugin Details

Severity: Medium

ID: 108378

File Name: samba_4_7_6.nasl

Version: 1.3

Type: remote

Family: Misc.

Published: 2018/03/15

Modified: 2018/08/16

Dependencies: 10785

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2018/03/13

Vulnerability Publication Date: 2018/03/13

Reference Information

CVE: CVE-2018-1050, CVE-2018-1057

BID: 103382, 103387