nginx < 0.7.64 / 0.8.x < 0.8.23 Multiple Vulnerabilities

Medium Nessus Plugin ID 107262

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to the self-reported version in its response header, the version of nginx hosted on the remote web server is less than 0.7.64 or 0.8.x prior to 0.8.23. It is, therefore, affected by multiple vulnerabilities as noted in the vendor advisory.

Solution

Upgrade to nginx version 0.7.64 / 0.8.23 or later.

See Also

http://nginx.org/en/security_advisories.html

Plugin Details

Severity: Medium

ID: 107262

File Name: nginx_0_7_64.nasl

Version: 1.3

Type: remote

Family: Web Servers

Published: 2018/03/09

Updated: 2019/04/05

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/09

Vulnerability Publication Date: 2009/11/09

Reference Information

CVE: CVE-2009-3555, CVE-2009-4487

CWE: 20, 310