nginx < 0.7.64 / 0.8.x < 0.8.23 Multiple Vulnerabilities

medium Nessus Plugin ID 107262


The remote web server is affected by multiple vulnerabilities.


According to the self-reported version in its response header, the version of nginx hosted on the remote web server is less than 0.7.64 or 0.8.x prior to 0.8.23. It is, therefore, affected by multiple vulnerabilities as noted in the vendor advisory.


Upgrade to nginx version 0.7.64 / 0.8.23 or later.

See Also

Plugin Details

Severity: Medium

ID: 107262

File Name: nginx_0_7_64.nasl

Version: 1.9

Type: combined

Agent: unix

Family: Web Servers

Published: 3/9/2018

Updated: 4/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2009-3555


Risk Factor: Medium

Score: 4.5


Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.5

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nginx:nginx

Required KB Items: installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/9/2009

Vulnerability Publication Date: 11/9/2009

Reference Information

CVE: CVE-2009-3555, CVE-2009-4487

CWE: 20, 310