4.1.0 -> 4.1-ESV-R15, 4.2.0 -> 4.2.8, 4.3.0 -> 4.3.6, 4.4.0 Multiple Vulnerabilities

High Nessus Plugin ID 107223


The DHCP server installed on the remote Linux host is affected by a buffer overflow vulnerability and a potential DoS.


The DHCP server version installed on the remote host is 4.1.0 to 4.1-ESV-R15, or 4.2.0 to 4.2.8, or 4.3.0 to 4.3.6, or 4.4.0.
It is, therefore, vulnerable to a denial of service condition with in the omapi_connection_writer() function of the omapip/buffer.c script due to improper handling of an empty message. A local attacker could potentially exhaust the available descriptors.


Please refer to the vendor's advisory.

See Also



Plugin Details

Severity: High

ID: 107223

File Name: isc_dhcp_AA-01565_AA-01567.nasl

Version: 1.1

Type: local

Family: Misc.

Published: 2018/03/08

Dependencies: 106203

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:isc:dhcp

Required KB Items: dhcp_server/type, dhcp_server/version, Settings/ParanoidReport

Patch Publication Date: 2018/02/28

Vulnerability Publication Date: 2018/02/28

Reference Information

CVE: CVE-2018-5732, CVE-2018-5733

BID: 103187, 103188

OSVDB: 175796, 175797

IAVB: 2018-B-0034