PHP 7.2.x < 7.2.3 Stack Buffer Overflow

critical Nessus Plugin ID 107219
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by a stack buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.3. It is, therefore, affected by a stack buffer overflow vulnerability.

Solution

Upgrade to PHP version 7.2.3 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.3

http://www.nessus.org/u?77aa0aa0

Plugin Details

Severity: Critical

ID: 107219

File Name: php_7_2_3.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 3/8/2018

Updated: 11/8/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2018-7584

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/1/2018

Vulnerability Publication Date: 3/1/2018

Reference Information

CVE: CVE-2018-7584