PHP 7.1.x < 7.1.15 Stack Buffer Overflow

critical Nessus Plugin ID 107218

Synopsis

The version of PHP running on the remote web server is affected by a stack buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.15. It is, therefore, affected by a stack buffer overflow vulnerability.

Solution

Upgrade to PHP version 7.1.15 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.15

http://www.nessus.org/u?77aa0aa0

Plugin Details

Severity: Critical

ID: 107218

File Name: php_7_1_15.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 3/8/2018

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2018-7584

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/1/2018

Vulnerability Publication Date: 3/1/2018

Reference Information

CVE: CVE-2018-7584