PHP 5.6.x < 5.6.34 Stack Buffer Overflow

high Nessus Plugin ID 107216
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The version of PHP running on the remote web server is affected by a stack buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.34. It is, therefore, affected by a stack buffer overflow vulnerability.

Solution

Upgrade to PHP version 5.6.34 or later.

See Also

http://www.nessus.org/u?77aa0aa0

http://php.net/ChangeLog-5.php#5.6.34

Plugin Details

Severity: High

ID: 107216

File Name: php_5_6_34.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 3/8/2018

Updated: 11/8/2019

Dependencies: php_version.nasl

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS Score Source: CVE-2018-7584

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/1/2018

Vulnerability Publication Date: 3/1/2018

Reference Information

CVE: CVE-2018-7584