Debian DSA-4133-1 : isc-dhcp - security update

High Nessus Plugin ID 107199

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the ISC DHCP client, relay and server. The Common Vulnerabilities and Exposures project identifies the following issues :

- CVE-2017-3144 It was discovered that the DHCP server does not properly clean up closed OMAPI connections, which can lead to exhaustion of the pool of socket descriptors available to the DHCP server, resulting in denial of service.

- CVE-2018-5732 Felix Wilhelm of the Google Security Team discovered that the DHCP client is prone to an out-of-bound memory access vulnerability when processing specially constructed DHCP options responses, resulting in potential execution of arbitrary code by a malicious DHCP server.

- CVE-2018-5733 Felix Wilhelm of the Google Security Team discovered that the DHCP server does not properly handle reference counting when processing client requests. A malicious client can take advantage of this flaw to cause a denial of service (dhcpd crash) by sending large amounts of traffic.

Solution

Upgrade the isc-dhcp packages.

For the oldstable distribution (jessie), these problems have been fixed in version 4.3.1-6+deb8u3.

For the stable distribution (stretch), these problems have been fixed in version 4.3.5-3+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887413

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891785

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891786

https://security-tracker.debian.org/tracker/CVE-2017-3144

https://security-tracker.debian.org/tracker/CVE-2018-5732

https://security-tracker.debian.org/tracker/CVE-2018-5733

https://security-tracker.debian.org/tracker/source-package/isc-dhcp

https://packages.debian.org/source/jessie/isc-dhcp

https://packages.debian.org/source/stretch/isc-dhcp

https://www.debian.org/security/2018/dsa-4133

Plugin Details

Severity: High

ID: 107199

File Name: debian_DSA-4133.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/03/08

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:isc-dhcp, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/03/07

Reference Information

CVE: CVE-2017-3144, CVE-2018-5732, CVE-2018-5733

DSA: 4133

IAVB: 2018-B-0034