Exim < 4.90.1 Buffer Overflow RCE Vulnerability

High Nessus Plugin ID 107149

Synopsis

The remote mail server is potentially affected by a buffer overflow vulnerability.

Description

According to its banner, the version of Exim running on the remote host is prior to 4.90.1. It is, therefore, potentially affected by a buffer overflow vulnerability. A flaw exists base64d() function due to improper validation of parsed messages. A remote attacker could potentially cause a buffer overflow condition and execute arbitrary code.

Solution

Upgrade to Exim 4.90.1 or later.

See Also

http://seclists.org/oss-sec/2018/q1/133

http://exim.org/static/doc/security/CVE-2018-6789.txt

ftp://ftp.exim.org/pub/exim/exim4/ChangeLog

http://www.nessus.org/u?4e4be781

Plugin Details

Severity: High

ID: 107149

File Name: exim_4_90_1.nasl

Version: 1.3

Type: remote

Published: 2018/03/06

Modified: 2018/03/16

Dependencies: 10263

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/10

Vulnerability Publication Date: 2018/02/07

Reference Information

CVE: CVE-2018-6789

BID: 103049

IAVB: 2018-B-0041