Exim < 4.90.1 Buffer Overflow RCE Vulnerability

High Nessus Plugin ID 107149


The remote mail server is potentially affected by a buffer overflow vulnerability.


According to its banner, the version of Exim running on the remote host is prior to 4.90.1. It is, therefore, potentially affected by a buffer overflow vulnerability. A flaw exists base64d() function due to improper validation of parsed messages. A remote attacker could potentially cause a buffer overflow condition and execute arbitrary code.


Upgrade to Exim 4.90.1 or later.

See Also





Plugin Details

Severity: High

ID: 107149

File Name: exim_4_90_1.nasl

Version: 1.9

Type: remote

Published: 2018/03/06

Updated: 2019/11/08

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6789

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/02/10

Vulnerability Publication Date: 2018/02/07

Exploitable With


Reference Information

CVE: CVE-2018-6789

BID: 103049