Debian DSA-4132-1 : libvpx - security update

High Nessus Plugin ID 107124


The remote Debian host is missing a security-related update.


It was discovered that incorrect validation of frame widths in the libvpx multimedia library may result in denial of service and potentially the execution of arbitrary code.


Upgrade the libvpx packages.

For the oldstable distribution (jessie), this problem has been fixed in version 1.3.0-3+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 1.6.1-3+deb9u1.

See Also

Plugin Details

Severity: High

ID: 107124

File Name: debian_DSA-4132.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2018/03/05

Modified: 2018/03/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libvpx, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/03/04

Reference Information

CVE: CVE-2017-13194

DSA: 4132