Ubuntu 14.04 LTS / 16.04 LTS / 17.10 : isc-dhcp vulnerabilities (USN-3586-1)

High Nessus Plugin ID 107117

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

Konstantin Orekhov discovered that the DHCP server incorrectly handled a large number of concurrent TCP sessions. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-2774)

It was discovered that the DHCP server incorrectly handled socket descriptors. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2017-3144)

Felix Wilhelm discovered that the DHCP client incorrectly handled certain malformed responses. A remote attacker could use this issue to cause the DHCP client to crash, resulting in a denial of service, or possibly execute arbitrary code. In the default installation, attackers would be isolated by the dhclient AppArmor profile.
(CVE-2018-5732)

Felix Wilhelm discovered that the DHCP server incorrectly handled reference counting. A remote attacker could possibly use this issue to cause the DHCP server to crash, resulting in a denial of service.
(CVE-2018-5733).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/3586-1/

Plugin Details

Severity: High

ID: 107117

File Name: ubuntu_USN-3586-1.nasl

Version: 3.6

Type: local

Agent: unix

Published: 2018/03/02

Modified: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-client, p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-relay, p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-server, p-cpe:/a:canonical:ubuntu_linux:isc-dhcp-server-ldap, cpe:/o:canonical:ubuntu_linux:14.04, cpe:/o:canonical:ubuntu_linux:16.04, cpe:/o:canonical:ubuntu_linux:17.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/03/01

Reference Information

CVE: CVE-2016-2774, CVE-2017-3144, CVE-2018-5732, CVE-2018-5733

USN: 3586-1

IAVB: 2018-B-0034