Asterisk 15.x < 15.2.2 Multiple Vulnerabilities (AST-2018-001 - AST-2018-006)

High Nessus Plugin ID 107100


A telephony application running on the remote host is affected by multiple vulnerabilities.


According to its SIP banner, the version of Asterisk running on the remote host is 15.x prior to 15.2.2. It is therefore, affected by multiple vulnerabilities as described in AST-2018-001, AST-2018-002, AST-2018-003, AST-2018-004, AST-2018-005, & AST-2018-006 advisories.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 15.2.2 or later.

See Also

Plugin Details

Severity: High

ID: 107100

File Name: asterisk_ast_2018_001-006.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2018/03/02

Modified: 2018/03/05

Dependencies: 63202

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/02/21

Vulnerability Publication Date: 2018/02/21

Reference Information

CVE: CVE-2018-7284, CVE-2018-7285, CVE-2018-7286, CVE-2018-7287

BID: 103120, 103129, 103149, 103151

OSVDB: 175405, 175406, 175408

IAVA: 2018-A-0064