Drupal 8.x < 8.4.5 Multiple Vulnerabilities (SA-CORE-2018-001)

Medium Nessus Plugin ID 107089

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.x prior to 8.4.5. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists with the Comment Reply Form. An authenticated remote attacker could add or view comments that they do not have access to. (CVE-2017-6926)

- A flaw exists with the Drupal.checkPlain() function due to improper handling of HTML injection. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the trust relationship between the browser and server. (CVE-2017-6927)

- A flaw exists with node access controls with a multilingual site due to defaulting to the untranslated version as a fallback. A remote attacker could potentially bypass access restrictions.
(CVE-2017-6930)

- A flaw exists with the Settings Tray module. A remote attacker could update data the do not have permission for. (CVE-2017-6931)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 8.4.5 or later.

See Also

https://www.drupal.org/SA-CORE-2018-001

https://www.drupal.org/project/drupal/releases/8.4.5

Plugin Details

Severity: Medium

ID: 107089

File Name: drupal_8_4_5.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2018/03/01

Modified: 2018/06/14

Dependencies: 18638

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Patch Publication Date: 2018/02/21

Vulnerability Publication Date: 2018/02/21

Reference Information

CVE: CVE-2017-6926, CVE-2017-6927, CVE-2017-6930, CVE-2017-6931

BID: 103115, 103138