Drupal 7.x < 7.57 Multiple Vulnerabilities (SA-CORE-2018-001)

Medium Nessus Plugin ID 107088

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.57. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists with the Drupal.checkPlain() function due to improper handling of HTML injection. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the trust relationship between the browser and server. (CVE-2017-6927)

- A flaw exists with the private file system due to improper checking of permissions when modules provided conflicting access. A remote attacker could potentially access sensitive files. (CVE-2017-6928)

- A flaw exists with the bundled jQuery due to improper handling of Ajax requests. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the trust relationship between the browser and server. (CVE-2017-6929)

- A flaw exists with the language switcher block due to improper validation of user input. A context-dependent attacker, with a specially crafted link, could redirect a user to a malicious site.
(CVE-2017-6932)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 7.57 or later.

See Also

https://www.drupal.org/SA-CORE-2018-001

https://www.drupal.org/project/drupal/releases/7.57

Plugin Details

Severity: Medium

ID: 107088

File Name: drupal_7_57.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2018/03/01

Modified: 2018/06/14

Dependencies: 18638

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 4.7

Temporal Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Patch Publication Date: 2018/02/21

Vulnerability Publication Date: 2018/02/21

Reference Information

CVE: CVE-2017-6927, CVE-2017-6928, CVE-2017-6929, CVE-2017-6932

BID: 103117, 103138