Arista Networks EOS Control Plane Packet Handling DoS (SA0025)

High Nessus Plugin ID 107068

Synopsis

The version of Arista Networks EOS running on the remote device is affected by a denial of service vulnerability.

Description

The version of Arista Networks EOS running on the remote device is affected by a denial of service vulnerability due to an unspecified flaw when handling certain packets sent to the control plane. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to cause the device to reboot.

Solution

Upgrade to Arista Networks EOS version 4.15.8M / 4.16.7M / 4.17.0F or later. Alternatively, apply the recommended patch referenced in the vendor advisory.

See Also

http://www.nessus.org/u?a1c1e1fe

Plugin Details

Severity: High

ID: 107068

File Name: arista_eos_sa0025.nasl

Version: 1.2

Type: combined

Family: Misc.

Published: 2018/02/28

Modified: 2018/02/28

Dependencies: 107070

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:arista:eos

Required KB Items: Host/Arista-EOS/Version, Host/Arista-EOS/eos_shell, Host/Arista-EOS/Model

Patch Publication Date: 2016/10/17

Vulnerability Publication Date: 2016/10/17

Reference Information

CVE: CVE-2016-6894

BID: 95267