Debian DSA-4126-1 : xmltooling - security update

High Nessus Plugin ID 107026


The remote Debian host is missing a security-related update.


Kelby Ludwig and Scott Cantor discovered that the Shibboleth service provider is vulnerable to impersonation attacks and information disclosure due to incorrect XML parsing. For additional details please refer to the upstream advisory at


Upgrade the xmltooling packages.

For the oldstable distribution (jessie), this problem has been fixed in version 1.5.3-2+deb8u3.

For the stable distribution (stretch), this problem has been fixed in version 1.6.0-4+deb9u1.

See Also

Plugin Details

Severity: High

ID: 107026

File Name: debian_DSA-4126.nasl

Version: 3.2

Type: local

Agent: unix

Published: 2018/02/28

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xmltooling, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/02/27

Reference Information

CVE: CVE-2018-0489

DSA: 4126

IAVB: 2018-B-0038