Debian DLA-1294-1 : golang security update

High Nessus Plugin ID 106985

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was an arbitrary command execution vulnerability in the Go programming language.

The 'go get' implementation did not correctly validate 'import path' statements for '://' which allowed remote attackers to execute arbitrary OS commands via a crafted website.

For Debian 7 'Wheezy', this issue has been fixed in golang version 2:1.0.2-1.1+deb7u3.

We recommend that you upgrade your golang packages. The Debian LTS team would like to thank Abhijith PA for preparing this update.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/02/msg00029.html

https://packages.debian.org/source/wheezy/golang

Plugin Details

Severity: High

ID: 106985

File Name: debian_DLA-1294.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2018/02/26

Modified: 2018/07/06

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:golang, p-cpe:/a:debian:debian_linux:golang-dbg, p-cpe:/a:debian:debian_linux:golang-doc, p-cpe:/a:debian:debian_linux:golang-go, p-cpe:/a:debian:debian_linux:golang-mode, p-cpe:/a:debian:debian_linux:golang-src, p-cpe:/a:debian:debian_linux:kate-syntax-go, p-cpe:/a:debian:debian_linux:vim-syntax-go, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/25

Reference Information

CVE: CVE-2018-7187