Debian DSA-4121-1 : gcc-6 - security update

High Nessus Plugin ID 106956

Synopsis

The remote Debian host is missing a security-related update.

Description

This update doesn't fix a vulnerability in GCC itself, but instead provides support for building retpoline-enabled Linux kernel updates.

Solution

Upgrade the gcc-6 packages.

For the stable distribution (stretch), this problem has been fixed in version 6.3.0-18+deb9u1.

See Also

https://packages.debian.org/source/stretch/gcc-6

http://www.debian.org/security/2018/dsa-4121

Plugin Details

Severity: High

ID: 106956

File Name: debian_DSA-4121.nasl

Version: Revision: 3.1

Type: local

Agent: unix

Published: 2018/02/23

Modified: 2018/02/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gcc-6, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/02/22

Reference Information

DSA: 4121