Jenkins < 2.89.4 / 2.107 Multiple Vulnerabilities

Medium Nessus Plugin ID 106951

Synopsis

A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.

Description

The version of Jenkins running on the remote web server is prior to 2.107 or is a version of Jenkins LTS prior to 2.89.4. It is, therefore, affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Jenkins to version 2.107 or later, Jenkins LTS to version 2.89.4 or later.

See Also

https://jenkins.io/security/advisory/2018-02-14/

Plugin Details

Severity: Medium

ID: 106951

File Name: jenkins_2_107.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2018/02/22

Modified: 2018/06/14

Dependencies: 65054

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 4.3

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: www/Jenkins

Patch Publication Date: 2018/02/14

Vulnerability Publication Date: 2018/02/14

Reference Information

CVE: CVE-2018-6356, CVE-2018-1000068, CVE-2018-1000102, CVE-2018-1000103

BID: 103037, 103101, 103209