Debian DSA-4117-1 : gcc-4.9 - security update

High Nessus Plugin ID 106875

Synopsis

The remote Debian host is missing a security-related update.

Description

This update doesn't fix a vulnerability in GCC itself, but instead provides support for building retpoline-enabled Linux kernel updates.

Solution

Upgrade the gcc-4.9 packages.

For the oldstable distribution (jessie), this problem has been fixed in version 4.9.2-10+deb8u1.

See Also

https://security-tracker.debian.org/tracker/gcc-4.9

https://packages.debian.org/source/jessie/gcc-4.9

http://www.debian.org/security/2018/dsa-4117

Plugin Details

Severity: High

ID: 106875

File Name: debian_DSA-4117.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2018/02/20

Modified: 2018/02/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gcc-4.9, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/02/17

Reference Information

DSA: 4117