Debian DSA-4116-1 : plasma-workspace - security update

High Nessus Plugin ID 106874


The remote Debian host is missing a security-related update.


Krzysztof Sieluzycki discovered that the notifier for removable devices in the KDE Plasma workspace performed insufficient sanitisation of FAT/VFAT volume labels, which could result in the execution of arbitrary shell commands if a removable device with a malformed disk label is mounted.


Upgrade the plasma-workspace packages.

For the stable distribution (stretch), this problem has been fixed in version 4:5.8.6-2.1+deb9u1.

See Also

Plugin Details

Severity: High

ID: 106874

File Name: debian_DSA-4116.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2018/02/20

Modified: 2018/03/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C


Base Score: 6.8

Vector: CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:plasma-workspace, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/02/16

Reference Information

CVE: CVE-2018-6791

DSA: 4116