Debian DLA-1285-1 : bind9 security update

High Nessus Plugin ID 106872

Synopsis

The remote Debian host is missing a security update.

Description

BIND, a DNS server implementation, was found to be vulnerable to a denial of service flaw was found in the handling of DNSSEC validation.
A remote attacker could use this flaw to make named exit unexpectedly with an assertion failure via a specially crafted DNS response. This issue is closely related to CVE-2017-3139.

For Debian 7 'Wheezy', these problems have been fixed in version 9.8.4.dfsg.P1-6+nmu2+deb7u20.

We recommend that you upgrade your bind9 packages.

For the detailed security status of bind9 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/bind9

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/02/msg00020.html

https://packages.debian.org/source/wheezy/bind9

https://security-tracker.debian.org/tracker/bind9

Plugin Details

Severity: High

ID: 106872

File Name: debian_DLA-1285.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2018/02/20

Modified: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: High

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bind9, p-cpe:/a:debian:debian_linux:bind9-doc, p-cpe:/a:debian:debian_linux:bind9-host, p-cpe:/a:debian:debian_linux:bind9utils, p-cpe:/a:debian:debian_linux:dnsutils, p-cpe:/a:debian:debian_linux:host, p-cpe:/a:debian:debian_linux:libbind-dev, p-cpe:/a:debian:debian_linux:libbind9-80, p-cpe:/a:debian:debian_linux:libdns88, p-cpe:/a:debian:debian_linux:libisc84, p-cpe:/a:debian:debian_linux:libisccc80, p-cpe:/a:debian:debian_linux:libisccfg82, p-cpe:/a:debian:debian_linux:liblwres80, p-cpe:/a:debian:debian_linux:lwresd, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/16

Reference Information

CVE: CVE-2018-5735