Debian DLA-1281-1 : advancecomp security update

Medium Nessus Plugin ID 106808

Synopsis

The remote Debian host is missing a security update.

Description

Joonun Jang discovered that the advzip tool in advancecomp, a collection of recompression utilities, was prone to a heap-based buffer overflow. This might allow an attacker to cause a denial of service (application crash) or other unspecified impact via a crafted file.

For Debian 7 'Wheezy', these problems have been fixed in version 1.15-1+deb7u1.

We recommend that you upgrade your advancecomp packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected advancecomp package.

See Also

https://lists.debian.org/debian-lts-announce/2018/02/msg00016.html

https://packages.debian.org/source/wheezy/advancecomp

Plugin Details

Severity: Medium

ID: 106808

File Name: debian_DLA-1281.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2018/02/14

Modified: 2018/09/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:advancecomp, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/13

Reference Information

CVE: CVE-2018-1056