Debian DLA-1278-1 : librsvg security update

Medium Nessus Plugin ID 106779

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was an input validation vulnerability in the librsvg renderer library that could result in data being leaked to remote attackers via a specially crafted file.

For Debian 7 'Wheezy', this issue has been fixed in librsvg version 2.36.1-2+deb7u3.

We recommend that you upgrade your librsvg packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/02/msg00013.html

https://packages.debian.org/source/wheezy/librsvg

Plugin Details

Severity: Medium

ID: 106779

File Name: debian_DLA-1278.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2018/02/13

Modified: 2018/07/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gir1.2-rsvg-2.0, p-cpe:/a:debian:debian_linux:librsvg2-2, p-cpe:/a:debian:debian_linux:librsvg2-bin, p-cpe:/a:debian:debian_linux:librsvg2-common, p-cpe:/a:debian:debian_linux:librsvg2-dbg, p-cpe:/a:debian:debian_linux:librsvg2-dev, p-cpe:/a:debian:debian_linux:librsvg2-doc, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/12

Reference Information

CVE: CVE-2018-1000041