EulerOS 2.0 SP1 : firefox (EulerOS-SA-2018-1043)

High Nessus Plugin ID 106771

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the firefox package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- Multiple flaws were found in the processing of malformed web content. A web page containing malicious content could cause Firefox to crash or, potentially, execute arbitrary code with the privileges of the user running Firefox. (CVE-2018-5089, CVE-2018-5091, CVE-2018-5095, CVE-2018-5096, CVE-2018-5097, CVE-2018-5098, CVE-2018-5099, CVE-2018-5102, CVE-2018-5103, CVE-2018-5104, CVE-2018-5117)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected firefox packages.

See Also

http://www.nessus.org/u?cf4730d6

Plugin Details

Severity: High

ID: 106771

File Name: EulerOS_SA-2018-1043.nasl

Version: 3.5

Type: local

Published: 2018/02/13

Modified: 2018/06/13

Dependencies: 12634

Risk Information

Risk Factor: High

Temporal Vector: CVSS2#E:U/RL:U/RC:UR

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:firefox, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Patch Publication Date: 2018/02/02

Reference Information

CVE: CVE-2018-5089, CVE-2018-5091, CVE-2018-5095, CVE-2018-5096, CVE-2018-5097, CVE-2018-5098, CVE-2018-5099, CVE-2018-5102, CVE-2018-5103, CVE-2018-5104, CVE-2018-5117