ProFTPD 1.3.4d / 1.3.5rc3 Denial of Service

Medium Nessus Plugin ID 106754

Synopsis

The remote FTP server is affected by a Denial of Service vulnerability.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.
According to its banner, the version of ProFTPD installed on the remote host is earlier than 1.3.5rc4 and is affected by a Denial of Service vulnerability in the mod_sftp_pam module.

Solution

Upgrade to ProFTPD version 1.3.5rc4 or later.

See Also

http://bugs.proftpd.org/show_bug.cgi?id=3973

Plugin Details

Severity: Medium

ID: 106754

File Name: proftpd_1_3_5_rc4.nasl

Version: $Revision: 1.2 $

Type: remote

Family: FTP

Published: 2018/02/12

Modified: 2018/02/13

Dependencies: 10084, 10092

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/proftpd, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/28

Vulnerability Publication Date: 2013/09/12

Reference Information

CVE: CVE-2013-4359

BID: 62328