ProFTPD < 1.3.4rc2 client-hostname restriction bypass

medium Nessus Plugin ID 106753
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FTP server is affected by a Denial of Service vulnerability.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.
According to its banner, the version of ProFTPD installed on the remote host is earlier than 1.3.4rc2 and is affected by a Denial of Service vulnerability in the mod_sftp module.

Solution

Upgrade to ProFTPD version 1.3.4rc2 or later.

See Also

http://bugs.proftpd.org/show_bug.cgi?id=3586

Plugin Details

Severity: Medium

ID: 106753

File Name: proftpd_1_3_4_rc2.nasl

Version: 1.3

Type: remote

Family: FTP

Published: 2/12/2018

Updated: 11/8/2019

Dependencies: ftp_overflow.nasl, ftpserver_detect_type_nd_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:POC/RL:OF/RC:ND

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/proftpd, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/6/2011

Vulnerability Publication Date: 1/24/2011

Reference Information

CVE: CVE-2011-1137

BID: 46183