ProFTPD < 1.3.2b / 1.3.3x < 1.3.3rc2 client-hostname restriction bypass

medium Nessus Plugin ID 106752
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FTP server is affected by a Denial of Service vulnerability.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.
According to its banner, the version of ProFTPD installed on the remote host is 1.3.2x prior to 1.3.2b or 1.3.3x prior to 1.3.3rc2 and is affected by a mitigation bypass vulnerability when the dNSNameRequired TLS option is enabled.

Solution

Upgrade to ProFTPD version 1.3.2b / 1.3.3rc2 or later.

See Also

http://bugs.proftpd.org/show_bug.cgi?id=3275

Plugin Details

Severity: Medium

ID: 106752

File Name: proftpd_1_3_3rc2.nasl

Version: 1.4

Type: remote

Family: FTP

Published: 2/12/2018

Updated: 11/8/2019

Dependencies: ftp_overflow.nasl, ftpserver_detect_type_nd_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 2.5

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/proftpd, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/20/2008

Vulnerability Publication Date: 8/6/2008

Reference Information

CVE: CVE-2009-3639

BID: 36804

CWE: 310