ProFTPD 1.3.1 SQL injection protection bypass

high Nessus Plugin ID 106750
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FTP server is affected by a mitigation bypass.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.
According to its banner, the version of ProFTPD installed on the remote host is 1.3.1x and may be affected by SQL injection protection bypass when NLS support is enabled.

Solution

Upgrade to ProFTPD version 1.3.2 or later.

See Also

http://bugs.proftpd.org/show_bug.cgi?id=3173

Plugin Details

Severity: High

ID: 106750

File Name: proftpd_1_3_1_sql_bypass.nasl

Version: 1.3

Type: remote

Family: FTP

Published: 2/12/2018

Updated: 11/8/2019

Dependencies: ftp_overflow.nasl, ftpserver_detect_type_nd_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.2

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/proftpd, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/5/2009

Vulnerability Publication Date: 2/5/2009

Reference Information

CVE: CVE-2009-0543

BID: 33650

CWE: 89